Instalar Virtualbox 2.1 nunha Ubuntu 8.04

marzo 12, 2009 at 9:40 am

function copiarPortapapeisGM_BoxValuesSession() { try { netscape.security.PrivilegeManager.enablePrivilege(“UniversalXPConnect”);const gClipboardHelper = Components.classes[“@mozilla.org/widget/clipboardhelper;1”].getService(Components.interfaces.nsIClipboardHelper);gClipboardHelper.copyString( document.getElementById(“GM_BoxValuesSession”).innerHTML );}catch(e){}}function pecharGM_BoxValuesSession() { document.getElementById(‘GM_BoxValuesSession’).parentNode.style.display = ‘none’;}

Vale, a cousa non é nada complexa aínda que ten un pequeno matiz debido a unhas dependencias que só están dispoñibles para a versión 8.10 de Ubuntu e non para a 8.04, así que deberemos de ter isto en contan máis adiante.

Ok, imos entón. Primeiro para instalar dende Synaptic debemos como sempre de modificar o sources.list engadindo os repositorios que necesitamos, na web de VirtualBox hai todos os que se precisan, no noso caso é o seguinte:

deb http://download.virtualbox.org/virtualbox/debian hardy non-free

Como sabes isto podes facelo dende o Synaptic, indo a Configuración-> Repositorios-> Sw de terceiros-> Engadir.

Logo descargas a -Sun public key- dende aquí, e dende Configuración-> Repositorios-> Autenticación -> Importar Clave , importas e engades a clave pública de SUN.

Moi ben, como ves na web de VBox todo iso podes facelo no terminal.

Vale, en principio xa esta o asunto, ‘perooooo’ se comezas a facer a instalación seguro que che produce un erro nas dependencias dado que VirtualBox:

Depende: libqt4-network (>=4.4.3) pero se va a instalar 4.4.0-1ubuntu5~hardy1
Depende: libqtcore4 (>=4.4.3) pero se va a instalar 4.4.0-1ubuntu5~hardy1
Depende: libqtgui4 (>=4.4.3) pero se va a instalar 4.4.0-1ubuntu5~hardy1

Ok, isto é debido a que en Hardy non hai ningunha versión >=4.4.3 desas bibliotecas, supoño que os responsables de VirtualBox en SUN ou non tiñan ganas de empaquetar VBox para a versión 8.04 ou se equivocar ao facer dita compilación. Isto arranxase engadindo como se indica na web de Ubuntu o seguinte repositorio:

deb http://fr.archive.ubuntu.com/ubuntu intrepid main

Desta forma conseguimos instalar na v8.04 as librerías necesarias que pertencen a v8.10.
Finito!! xa solo queda marcar para instalar.

Por certo eliminarase a antiga instalación de VBox que teñamos pero non os .vdi que teñamos creados das máquinas, así que se eliminamos toda a configuración non pasa nada dado que é cuestión de un minuto crear outra máquina virtual co .vdi que segue persistente.

S2!

Actualización_

Como me comenta Óscar Casal, sería bo que logo de facer a instalación comentasemos a última liña que engadimos ao sources.list para conseguir instalar as dependencias da versión v8.10 dado que non vai ser que algún lle de por actualizar todo o sistema. Asi que OLLO!!! e comentade a citada liña.

#deb http://fr.archive.ubuntu.com/ubuntu intrepid main

Ou ben dende Configuración-> Repositorios-> Sw de terceiros-> Engadir e desmarcades a liña onde aparece a entrada.

Listo!

Entry filed under: Administrar Sistemas, Servidores, Virutalización. Tags: .

Renegados, caciques e parvos Eterno Carabuxo


Calendario

marzo 2009
L M X J V S D
« Feb   Abr »
 1
2345678
9101112131415
16171819202122
23242526272829
3031  

Suscríbete as miñas novas

Powered by FeedBurner

Firefox

Android